[ Обновленные темы · Новые сообщения · Участники · Правила форума · Поиск · RSS ]
Форум » Ленточный вариант форума
Новые сообщения
agkorepanovДата: Понедельник, 05.10.2020, 22:46 | Сообщение # 1
Форум: Иж-Софт - Форум по 1С | Тема: Сворачивание огромных баз 1С 7.7.
Admin
Группа: Администраторы
Сообщений: 205
Репутация: 0
Статус: Offline
Если кому то надо, то пишите, у меня есть супер обработка по сворачиванию огромных баз за считанные минуты. Стандартная обработка будет делать это несколько недель )))
 
agkorepanovДата: Понедельник, 05.10.2020, 22:43 | Сообщение # 2
Форум: Иж-Софт - Форум по 1С | Тема: Пересчет итогов для отдельных DBF таблиц 1С:Предприятие 7.7
Admin
Группа: Администраторы
Сообщений: 205
Репутация: 0
Статус: Offline
Если у вас в отчетах не правильные цифры, к тому же итоговые цифры то появляются то исчезают в зависимости от выбранного периода, значит у вас произошло разрушение. Такое могло появится еще если нестандартная свертка делалась напрямую к таблицам.

Создаем копию рабочей базы и в ней всё будем делать.
В файле 1cv7.dd ищем название нужной таблицы которую будем восстанавливать.

Пример: кусок файла 1cv7.dd
#===============================================================================
#==TABLE no 532    : Регистр Покупатели
# Name    |Descr                         |Type[A/S/U]|DBTableName|ReUsable  
T=RG4335  |Регистр Покупатели            |A          |RG4335     |1   

4. Удаляем из копии базы файлы неисправных итогов RGxxxx.DBF и RGxxxx.CDX взятых из 1cv7.dd (файл движений RAxxxx соответствует файлу итогов RGxxxx)
5. Переносим из копии базы все RA*.* и RG*.* файлы в отдельный каталог, за исключением RAxxxx.DBF (и RAxxxx.CDX) взятых из 1cv7.dd
6. В конфигураторе копии делаем пересчет итогов. При этом пересчет итогов будет сделан по оставшимся регистрам RAxxxx.DBF и создадутся пустые файлы итогов по остальным регистрам. Закрываем конфигуратор.
7. Возвращаем на место в копию ранее перенесенные RA/RG, при этом перезапишутся пустые файлы итогов (см. п.4.)
8. ТА, ГП и пр. в полученной базе измениться не должны, файлы/состояние УРИБ те же что и в рабочей базе.
После проверки копии "на адекватность" заменяем рабочую базу полученной копией.

Всё.
 
agkorepanovДата: Понедельник, 10.08.2020, 18:14 | Сообщение # 3
Форум: Иж-Софт - Форум по 1С | Тема: "следующие настройки программы имеют недопустимые в базовой
Admin
Группа: Администраторы
Сообщений: 205
Репутация: 0
Статус: Offline
Для УТ 11 сделал конвертацию из проф в базовую. После этого, при проведении документов, выходит ошибка "следующие настройки программы имеют недопустимые в базовой версии значения"
Чтобы её исправить нужно 
1) Открыть конфигуратор - Администрирование - Пользователи - Открываем необходимого пользователя - Находим роль - Ставим галочку «Режим «Все функции» - закрываем конфигураторатор.

2) Открываем 1С  - В левом верхнем углу нажимаем на круглую кнопку с треугольником -  выбираем Сервис -  Параметры -  Ставим галочку «Отображать команду «Все функции»

3) В правом верхнем углу нажимаем нажимаем кнопку и в меню  - Для технического специалиста - Константы - Ищем константу "Базовая версия" и ставим галочку.
 
agkorepanovДата: Среда, 24.04.2019, 12:13 | Сообщение # 4
Форум: Иж-Софт - Форум по 1С | Тема: Декларации по НДС за 1 квартал 2019 года
Admin
Группа: Администраторы
Сообщений: 205
Репутация: 0
Статус: Offline
Проблемы со сдачей Декларации по НДС за 1 квартал 2019 года в 1С 7.7. Бухгалтерия и Комплексная.  Не заполняются колноки с 14 по 18 , а если заполняется то только 10% НДС. Для решения нужно скачать этот файл  , и переименовать его в "КнигаПродаж1137" зайти в конфигуратор , найти Отчеты - КнигаПродаж1137 нажать на неё правой кнопкой мыши и заменить на внешний отчет .
 
agkorepanovДата: Пятница, 10.08.2018, 14:10 | Сообщение # 5
Форум: Иж-Софт - Форум по 1С | Тема: Выдает ошибку возможны расхождения ИБ и ФР. Неверная длина.
Admin
Группа: Администраторы
Сообщений: 205
Репутация: 0
Статус: Offline
Принтер Атол ф11.
Выдает ошибку возможны расхождения ИБ и ФР. Неверная длина.

Ответ: Проблема в том что длина наименования товара больше 64 символов. Как вариант решения можно зайти в процедуру ФискализацияЧека которая находится в модуле документа Чек, и там ограничить длину наименования товара .
 
agkorepanovДата: Среда, 13.06.2018, 18:05 | Сообщение # 6
Форум: Иж-Софт - Форум по 1С | Тема: Тип не определен (СправочникСсылка.КлассификаторБанковРФ)
Admin
Группа: Администраторы
Сообщений: 205
Репутация: 0
Статус: Offline
При загрузке данных в  Управление торговлей, редакция 11 (11.4.3.167)  из  Розница (базовая), редакция 2.2 (2.2.8.29) в журнале регистрации выходит ошибка

{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(14942)}: Тип не определен (СправочникСсылка.КлассификаторБанковРФ)
            СоответствиеТипа.Вставить(ИмяУзла, Тип(ПравилаОбмена.Значение));
 
agkorepanovДата: Четверг, 24.05.2018, 15:03 | Сообщение # 7
Форум: Иж-Софт - Форум по 1С | Тема: УТ 10.3 при печати на Атол 55F чек анулировался
Admin
Группа: Администраторы
Сообщений: 205
Репутация: 0
Статус: Offline
В программе УТ 10.3 при печати на Атол 55F если указать скидку , или товаров слишком много в чеке, то чек анулировался . Чтобы решить эту проблему нужно поменять драйвер Атола с 8.16 на 8.14.

скачать можно тут

http://kkm-on-line.ru/index.p....4-02-02
 
agkorepanovДата: Понедельник, 26.02.2018, 11:25 | Сообщение # 8
Форум: Иж-Софт - Форум по 1С | Тема: обмен Ут 10.3 и БП 3.0 ошибка
Admin
Группа: Администраторы
Сообщений: 205
Репутация: 0
Статус: Offline
Ошибка в обработчике события ПередПолучениемИзмененныхОбъектов (конвертация) 
    Обработчик             =  ПередПолучениемИзмененныхОбъектов (конвертация) 
    ОписаниеОшибки         =  Ошибка компиляции при вычислении выражения или выполнении фрагмента кода: {(2,51)}: Переменная не определена (Получатель) 
    ПозицияМодуля          =  Обработка.ОбменДаннымиXML.МодульОбъекта(12166)
    КодСообщения           =  175

чтобы исправить эту ошибку надо обмен делать через пункт "Сервис- Обмен данными с продуктами 8.2" а не через обычный старый обмен который работает только для БП 2.0
 
agkorepanovДата: Среда, 21.02.2018, 15:18 | Сообщение # 9
Форум: Иж-Софт - Форум по 1С | Тема: Как передать параметры в форму 1С 8
Admin
Группа: Администраторы
Сообщений: 205
Репутация: 0
Статус: Offline
Как открыть обычную форму и передать в неё параметры, а потом открыть эти параметры 

НоваяФорма = ПолучитьФорму("ФормаМенеджера");

НоваяФорма.номенклатура = Ссылка;

НоваяФорма.Открыть();

// Номенклатура это реквизит формы. То есть передача параметра происходит через реквизит формы
 
agkorepanovДата: Пятница, 16.02.2018, 14:25 | Сообщение # 10
Форум: Иж-Софт - Форум по 1С | Тема: Как получить свойство объекта 1С 8 УТ 10.3
Admin
Группа: Администраторы
Сообщений: 205
Репутация: 0
Статус: Offline
Функция ПолучитьНазначениеСвойства(Объект) Экспорт
// Возьмем все назначения свойств
ТекстЗапроса = "ВЫБРАТЬ
               | НазначенияСвойствКатегорийОбъектов.Ссылка КАК НазначениеСвойства
               |ИЗ
               | ПланВидовХарактеристик.НазначенияСвойствКатегорийОбъектов КАК НазначенияСвойствКатегорийОбъектов
               |ГДЕ
               | НазначенияСвойствКатегорийОбъектов.ПометкаУдаления = ЛОЖЬ";
Запрос = Новый Запрос(ТекстЗапроса);
Результат = Запрос.Выполнить().Выгрузить();
// Пройдем по всем и посмотрим какой нам подходит
Для Каждого Строка Из Результат Цикл
Если Объект <> Неопределено И Строка.НазначениеСвойства.ТипЗначения = Новый ОписаниеТипов("СправочникСсылка." + Объект.Метаданные().Имя) Тогда
Возврат Строка.НазначениеСвойства;
КонецЕсли;
КонецЦикла;
//
// Ничего не нашли
Возврат ПланыВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.ПустаяСсылка();
//
КонецФункции

Функция НайтиСвойство(Объект, Свойство) Экспорт
ТекстЗапроса = "ВЫБРАТЬ
               | СвойстваОбъектов.Ссылка КАК Свойство
               |ИЗ
               | ПланВидовХарактеристик.СвойстваОбъектов КАК СвойстваОбъектов
               |ГДЕ
               | СвойстваОбъектов.Наименование = &Наименование
               | И (&НазначениеСвойства = ЗНАЧЕНИЕ(ПланВидовХарактеристик.НазначенияСвойствКатегорийОбъектов.ПустаяСсылка)
               | ИЛИ СвойстваОбъектов.НазначениеСвойства = &НазначениеСвойства)";
Запрос = Новый Запрос(ТекстЗапроса);
Запрос.УстановитьПараметр("Наименование", Свойство);
// Выберем назначение исходя из типа объекта 
НазначениеСвойства = ПолучитьНазначениеСвойства(Объект);
Запрос.УстановитьПараметр("НазначениеСвойства", НазначениеСвойства);
// Посмотрим, нашли мы свойство или нет
Результат = Запрос.Выполнить().Выгрузить();
Если Результат.Количество() = 0 Тогда
Возврат Неопределено;
Иначе
Возврат Результат[0].Свойство;
КонецЕсли;
КонецФункции

Функция ПолучитьСвойствоОбъекта(Объект, Свойство) Экспорт
// Получим список свойств для объекта
ТекстЗапроса = "ВЫБРАТЬ
               | ЗначенияСвойствОбъектов.Значение
               |ИЗ
               | РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
               |ГДЕ
               | ЗначенияСвойствОбъектов.Объект = &Объект
               | И ЗначенияСвойствОбъектов.Свойство = &Свойство";
   
Запрос = Новый Запрос(ТекстЗапроса);
Запрос.УстановитьПараметр("Объект", Объект);
// Если свойство передано по названию, то попытаемся найти его
Если ТипЗнч(Свойство) = Тип("Строка") Тогда
НайденноеСвойство = НайтиСвойство(Объект, Свойство);
Если НайденноеСвойство = Неопределено Тогда
Возврат Неопределено;
Иначе
Запрос.УстановитьПараметр("Свойство", НайденноеСвойство);
КонецЕсли;
Иначе
Запрос.УстановитьПараметр("Свойство", Свойство);
КонецЕсли;
//
Результат = Запрос.Выполнить().Выгрузить();
Если Результат.Количество() = 0 Тогда
Возврат Неопределено;
Иначе
Возврат Результат[0].Значение;
КонецЕсли;
Конецфункции
 
agkorepanovДата: Пятница, 01.12.2017, 17:20 | Сообщение # 11
Форум: Иж-Софт - Форум по 1С | Тема: в заголовке табличной части отображалось количество строк
Admin
Группа: Администраторы
Сообщений: 205
Репутация: 0
Статус: Offline
Вопрос: Как сделать чтобы в заголовке табличной части отображалось количество строк (позиций)

Ответ: У формы документа есть событие "ОбновлениеОтображения". В конфигурации Управление торговлей 10.3 в нем добавлена такая строка : 

ЭлементыФормы.ПанельФормы.Страницы.Товары.Заголовок = "Товары и услуги (" + Товары.Количество() + " поз.)";
 
agkorepanovДата: Пятница, 01.12.2017, 16:07 | Сообщение # 12
Форум: Иж-Софт - Форум по 1С | Тема: Как сделать колонку недоступной 1С 8
Admin
Группа: Администраторы
Сообщений: 205
Репутация: 0
Статус: Offline
Если Элемент.ТекущаяСтрока.НомерСтроки>1 и Элемент.ТекущаяКолонка.Имя="ИмяКолонки" Тогда Элемент.ТекущаяКолонка.ТолькоПросмотр=Истина;
КонецЕсли;

В целом колонку недоступной сделать очень легко:

  ЭлементыФормы.ВозвратОтказ.Колонки.Решение.Доступность=Ложь;
    
Но если мы хотим сделать недоступной конкретную ячейку то надо зайти в свойства табличного поля и найти в ней событиие "ПриАктивизацииКолонки"
и там внутри добавить: 

Если  Элемент.ТекущаяКолонка.Имя="ИМЯ_КОЛОНКИ" Тогда
  Элемент.ТекущаяКолонка.ТолькоПросмотр=Истина;
КонецЕсли; 
    

 
agkorepanovДата: Среда, 29.11.2017, 13:44 | Сообщение # 13
Форум: Иж-Софт - Форум по 1С | Тема: Как добавить отбор к табличному полю 1С 8 обычные формы
Admin
Группа: Администраторы
Сообщений: 205
Репутация: 0
Статус: Offline
Как добавить отбор к табличному полю 1С 8 обычные формы 

ЭлементыФормы.НАЗВАНИЕТАБЛИЧНОЙЧАСТИ.Значение.Отбор.НАЗВАНИЕКОЛОНКИ.установить(Перечисления.ВидыСобытий.Претензия);
 
agkorepanovДата: Четверг, 05.10.2017, 15:37 | Сообщение # 14
Форум: Иж-Софт - Форум по 1С | Тема: Печать внешней формы программно из УТ 10.3
Admin
Группа: Администраторы
Сообщений: 205
Репутация: 0
Статус: Offline
ДеревоМакетовПечати = УниверсальныеМеханизмы.ПолучитьДеревоМакетовПечати(ЭтотОбъект, Неопределено);
СтрокаКнопки = ДеревоМакетовПечати.Строки.Найти("НАЗВАНИЕ_ВАШЕЙ_ФОРМЫ","Текст");

Если СтрокаКнопки=Неопределено тогда
Предупреждение("Не найдена форма с названием -НАЗВАНИЕ_ВАШЕЙ_ФОРМЫ-");
конецеслИ;

Расшифровка = СтрокаКнопки.Расшифровка;
Если ТипЗнч(Расшифровка) = Тип("Структура") Тогда
ТабДокумент = УниверсальныеМеханизмы.НапечататьВнешнююФорму(ЭтотОбъект, Расшифровка);
Если ТабДокумент <> Неопределено Тогда
УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент);
КонецЕсли;
КонецЕсли;
 
agkorepanovДата: Понедельник, 03.07.2017, 00:18 | Сообщение # 15
Форум: Иж-Софт - Форум по 1С | Тема: 1С 7.7. Разрастается файл CDX регистра.
Admin
Группа: Администраторы
Сообщений: 205
Репутация: 0
Статус: Offline
Вопрос: Разрастается файл CDX регистра.

Ответ:
Разрастается RG****.CDX
Находим в базе файл с расширением DD открываем блокнотом и в нем находим #----Indexes------ у глуканутой таблицы и убираем от туда поля которые начинаются с SP

После этого удаляем файл CDX
и заходим монопольно в базу чтобы создался новый файл.
 
Поиск: